Latency experienced in Platform
Incident Report for GovOS Studio
Resolved
This incident has been resolved and operational performance has been restored.
Posted Feb 14, 2024 - 18:47 EST
Monitoring
A fix has been implemented and we are monitoring the results
Posted Feb 14, 2024 - 18:21 EST
Investigating
We are currently experiencing latency where there may be issues loading forms and/or the lobby to edit forms.
Posted Feb 14, 2024 - 17:47 EST
This incident affected: SeamlessDocs Site.