Issues with Known Lists in Signature Workflows
Incident Report for GovOS Studio
Resolved
This incident has been resolved.
Posted Oct 06, 2022 - 16:48 EDT
Monitoring
A fix has been implemented and we are monitoring the results
Posted Oct 06, 2022 - 16:41 EDT
Identified
We have identified the cause of issue and are developing a fix
Posted Oct 06, 2022 - 15:52 EDT
Investigating
We are investigating an issue where in some cases the selection made from a Known List of signers is being sent to an incorrect email address. This is being treated as a top priority and we expect more information on a resolution soon.
Posted Oct 06, 2022 - 14:33 EDT
This incident affected: SeamlessDocs Site.