Increased Latency in Accessing Forms
Incident Report for GovOS Studio
Resolved
This incident has been resolved. If you notice any other issues, please don't hesitate to reach out to our support team via live chat or by emailing support@seamlessdocs.com

Thank you!
Posted Aug 20, 2021 - 14:37 EDT
Investigating
Users have reported having difficulty accessing forms due to increased loading times and we are investigating further
Posted Aug 20, 2021 - 14:12 EDT
This incident affected: SeamlessDocs Site.